import Foundation
let pattern = #"\b(\S)\s+(?=\S\b)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Text where s o m e parts are s h r u n k"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)