using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(\S)\s+(?=\S\b)";
string substitution = @"$1";
string input = @"Text where s o m e parts are s h r u n k";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}