$re = '/\b(\S)\s+(?=\S\b)/';
$str = 'Text where s o m e parts are s h r u n k';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;