re = /\b(\S)\s+(?=\S\b)/
str = 'Text where s o m e parts are s h r u n k'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result