import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*(((\\/\\/|#)[^\\n]*\\n*)|(\\/\\*((?!\\*\\/)(.|\\n))+\\*\\/)|\\s)*\\s*(\\$|echo|class\\s+\\w|\\/\\/php|#php|mysql_|namespace|use|include|require|function\\s+[^\\(\\s]+\\s*\\(\\s*\\$|((if|while|for|switch|foreach)\\s*\\(\\s*\\$\\w))";
final String string = "// nějaké podmínky\n"
+ "if($sel->ulcp != $ulcp){$co .= \", ulcp = '$ulcp'\";}\n"
+ "if($sel->ulcp2 != $ulcp2){$co .= \", ulcp2 = '$ulcp2'\";}\n"
+ "if($sel->ulcp3 != $ulcp3){$co .= \", ulcp3 = '$ulcp3'\";}";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}