use strict;
my $str = '// nějaké podmínky
if($sel->ulcp != $ulcp){$co .= ", ulcp = \'$ulcp\'";}
if($sel->ulcp2 != $ulcp2){$co .= ", ulcp2 = \'$ulcp2\'";}
if($sel->ulcp3 != $ulcp3){$co .= ", ulcp3 = \'$ulcp3\'";}';
my $regex = qr/^\s*(((\/\/|#)[^\n]*\n*)|(\/\*((?!\*\/)(.|\n))+\*\/)|\s)*\s*(\$|echo|class\s+\w|\/\/php|#php|mysql_|namespace|use|include|require|function\s+[^\(\s]+\s*\(\s*\$|((if|while|for|switch|foreach)\s*\(\s*\$\w))/ip;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}