const regex = /^\s*(((\/\/|#)[^\n]*\n*)|(\/\*((?!\*\/)(.|\n))+\*\/)|\s)*\s*(\$|echo|class\s+\w|\/\/php|#php|mysql_|namespace|use|include|require|function\s+[^\(\s]+\s*\(\s*\$|((if|while|for|switch|foreach)\s*\(\s*\$\w))/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*(((\\\/\\\/|#)[^\\n]*\\n*)|(\\\/\\*((?!\\*\\\/)(.|\\n))+\\*\\\/)|\\s)*\\s*(\\$|echo|class\\s+\\w|\\\/\\\/php|#php|mysql_|namespace|use|include|require|function\\s+[^\\(\\s]+\\s*\\(\\s*\\$|((if|while|for|switch|foreach)\\s*\\(\\s*\\$\\w))', 'i')
const str = `// nějaké podmínky
if(\$sel->ulcp != \$ulcp){\$co .= ", ulcp = '\$ulcp'";}
if(\$sel->ulcp2 != \$ulcp2){\$co .= ", ulcp2 = '\$ulcp2'";}
if(\$sel->ulcp3 != \$ulcp3){\$co .= ", ulcp3 = '\$ulcp3'";}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}