re = /^\s*(((\/\/|#)[^\n]*\n*)|(\/\*((?!\*\/)(.|\n))+\*\/)|\s)*\s*(\$|echo|class\s+\w|\/\/php|#php|mysql_|namespace|use|include|require|function\s+[^\(\s]+\s*\(\s*\$|((if|while|for|switch|foreach)\s*\(\s*\$\w))/i
str = '// nějaké podmínky
if($sel->ulcp != $ulcp){$co .= ", ulcp = \'$ulcp\'";}
if($sel->ulcp2 != $ulcp2){$co .= ", ulcp2 = \'$ulcp2\'";}
if($sel->ulcp3 != $ulcp3){$co .= ", ulcp3 = \'$ulcp3\'";}'
# Print the match result
str.match(re) do |match|
puts match.to_s
end