package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([A-N,P-Z,0-9]){6}\.([A-N,P-Z,0-9]){5}\.(LE|SL|ME|BR|SP)\.[0-9]{3}$`)
var str = `ADN123.FG4FE3.LE.999`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}