re = /^([A-N,P-Z,0-9]){6}\.([A-N,P-Z,0-9]){5}\.(LE|SL|ME|BR|SP)\.[0-9]{3}$/
str = 'ADN123.FG4FE3.LE.999'
# Print the match result
str.match(re) do |match|
puts match.to_s
end