#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[\d]+[,|.]?[\d]+[\ ]?[д|с|м|мк|н|п|ф|а|з|и]+[Ф]"
Local $sString = "SMD 0603 49,9 Ом ±1% 0,1 Вт CR0603-FX-49R9ELF" & @CRLF & _
"SMD 0603 49,9 Ом ± 1% 0,1Вт CR0603-FX-49R9ELF" & @CRLF & _
"" & @CRLF & _
"SMD 0603 49,9 Ом ±1% 0.1 Вт CR0603-FX-49R9ELF" & @CRLF & _
"SMD 0603 49,9 Ом ± 1% 0.1Вт CR0603-FX-49R9ELF" & @CRLF & _
"" & @CRLF & _
"SMD 0603 49,9 Ом ±1% 0.11 Вт CR0603-FX-49R9ELF" & @CRLF & _
"SMD 0603 49,9 Ом ± 1% 0.11Вт CR0603-FX-49R9ELF" & @CRLF & _
"" & @CRLF & _
"SMD 0805 100 нФ ± 10 % 50 В X7R 08055C104KAT2A AVX" & @CRLF & _
"SMD 0805 100 нФ ±10% 50В X7R 08055C104KAT2A AVX" & @CRLF & _
"" & @CRLF & _
"SMD 0805 100 нФ ± 10 % 50.0 В X7R 08055C104KAT2A AVX" & @CRLF & _
"SMD 0805 100 нФ ±10% 50.0В X7R 08055C104KAT2A AVX" & @CRLF & _
"" & @CRLF & _
"50.9В" & @CRLF & _
"50.99Вт" & @CRLF & _
"50.9 В" & @CRLF & _
"50.999 Вт" & @CRLF & _
"а50ю" & @CRLF & _
"100.00 мкФ" & @CRLF & _
"100.00 нФ" & @CRLF & _
"100.00 пФ" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")