use strict;
my $str = 'SMD 0603 49,9 Ом ±1% 0,1 Вт CR0603-FX-49R9ELF
SMD 0603 49,9 Ом ± 1% 0,1Вт CR0603-FX-49R9ELF
SMD 0603 49,9 Ом ±1% 0.1 Вт CR0603-FX-49R9ELF
SMD 0603 49,9 Ом ± 1% 0.1Вт CR0603-FX-49R9ELF
SMD 0603 49,9 Ом ±1% 0.11 Вт CR0603-FX-49R9ELF
SMD 0603 49,9 Ом ± 1% 0.11Вт CR0603-FX-49R9ELF
SMD 0805 100 нФ ± 10 % 50 В X7R 08055C104KAT2A AVX
SMD 0805 100 нФ ±10% 50В X7R 08055C104KAT2A AVX
SMD 0805 100 нФ ± 10 % 50.0 В X7R 08055C104KAT2A AVX
SMD 0805 100 нФ ±10% 50.0В X7R 08055C104KAT2A AVX
50.9В
50.99Вт
50.9 В
50.999 Вт
а50ю
100.00 мкФ
100.00 нФ
100.00 пФ
';
my $regex = qr/[\d]+[,|.]?[\d]+[\ ]?[д|с|м|мк|н|п|ф|а|з|и]+[Ф]/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}