# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[\d]+[,|.]?[\d]+[\ ]?[д|с|м|мк|н|п|ф|а|з|и]+[Ф]"
test_str = ("SMD 0603 49,9 Ом ±1% 0,1 Вт CR0603-FX-49R9ELF\n"
"SMD 0603 49,9 Ом ± 1% 0,1Вт CR0603-FX-49R9ELF\n\n"
"SMD 0603 49,9 Ом ±1% 0.1 Вт CR0603-FX-49R9ELF\n"
"SMD 0603 49,9 Ом ± 1% 0.1Вт CR0603-FX-49R9ELF\n\n"
"SMD 0603 49,9 Ом ±1% 0.11 Вт CR0603-FX-49R9ELF\n"
"SMD 0603 49,9 Ом ± 1% 0.11Вт CR0603-FX-49R9ELF\n\n"
"SMD 0805 100 нФ ± 10 % 50 В X7R 08055C104KAT2A AVX\n"
"SMD 0805 100 нФ ±10% 50В X7R 08055C104KAT2A AVX\n\n"
"SMD 0805 100 нФ ± 10 % 50.0 В X7R 08055C104KAT2A AVX\n"
"SMD 0805 100 нФ ±10% 50.0В X7R 08055C104KAT2A AVX\n\n"
"50.9В\n"
"50.99Вт\n"
"50.9 В\n"
"50.999 Вт\n"
"а50ю\n"
"100.00 мкФ\n"
"100.00 нФ\n"
"100.00 пФ\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.