using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\d]+[,|.]?[\d]+[\ ]?[д|с|м|мк|н|п|ф|а|з|и]+[Ф]";
string input = @"SMD 0603 49,9 Ом ±1% 0,1 Вт CR0603-FX-49R9ELF
SMD 0603 49,9 Ом ± 1% 0,1Вт CR0603-FX-49R9ELF
SMD 0603 49,9 Ом ±1% 0.1 Вт CR0603-FX-49R9ELF
SMD 0603 49,9 Ом ± 1% 0.1Вт CR0603-FX-49R9ELF
SMD 0603 49,9 Ом ±1% 0.11 Вт CR0603-FX-49R9ELF
SMD 0603 49,9 Ом ± 1% 0.11Вт CR0603-FX-49R9ELF
SMD 0805 100 нФ ± 10 % 50 В X7R 08055C104KAT2A AVX
SMD 0805 100 нФ ±10% 50В X7R 08055C104KAT2A AVX
SMD 0805 100 нФ ± 10 % 50.0 В X7R 08055C104KAT2A AVX
SMD 0805 100 нФ ±10% 50.0В X7R 08055C104KAT2A AVX
50.9В
50.99Вт
50.9 В
50.999 Вт
а50ю
100.00 мкФ
100.00 нФ
100.00 пФ
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}