#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(Group1|GroupOne)(?!$)(,(Group2|GroupTwo))?(,(Group3|GroupThree))?$"
Local $sString = "Group1,GroupTwo" & @CRLF & _
"Group1,GroupThree" & @CRLF & _
"Group1,GroupTwo,GroupThree" & @CRLF & _
"Group1" & @CRLF & _
"Group1,Group4" & @CRLF & _
"Group2,Group4" & @CRLF & _
"Group2" & @CRLF & _
"Group1," & @CRLF & _
"Group1,GroupTwo,GroupTwo" & @CRLF & _
"Group1,Group3,Group2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")