use strict;
my $str = 'Group1,GroupTwo
Group1,GroupThree
Group1,GroupTwo,GroupThree
Group1
Group1,Group4
Group2,Group4
Group2
Group1,
Group1,GroupTwo,GroupTwo
Group1,Group3,Group2';
my $regex = qr/(Group1|GroupOne)(?!$)(,(Group2|GroupTwo))?(,(Group3|GroupThree))?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}