re = /(Group1|GroupOne)(?!$)(,(Group2|GroupTwo))?(,(Group3|GroupThree))?$/m
str = 'Group1,GroupTwo
Group1,GroupThree
Group1,GroupTwo,GroupThree
Group1
Group1,Group4
Group2,Group4
Group2
Group1,
Group1,GroupTwo,GroupTwo
Group1,Group3,Group2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end