using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(Group1|GroupOne)(?!$)(,(Group2|GroupTwo))?(,(Group3|GroupThree))?$";
string input = @"Group1,GroupTwo
Group1,GroupThree
Group1,GroupTwo,GroupThree
Group1
Group1,Group4
Group2,Group4
Group2
Group1,
Group1,GroupTwo,GroupTwo
Group1,Group3,Group2";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}