#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m):\s\+?(\(?[0-9]+\)?\s?)+"
Local $sString = "tel/mob: 001 433 123 4352" & @CRLF & _
"tel/mob: 0014331234352" & @CRLF & _
"tel: 001 433 123 4352" & @CRLF & _
"tel: 0014331234352" & @CRLF & _
"tel/mob: 001 (433) 123 4352" & @CRLF & _
"tel: 001 (433) 123 4352" & @CRLF & _
"tel/mob: +1 433 123 4352" & @CRLF & _
"tel/mob: +14331234352" & @CRLF & _
"tel: +1 433 123 4352" & @CRLF & _
"tel: +14331234352" & @CRLF & _
"tel/mob: +1 (433) 123 4352" & @CRLF & _
"tel: +1 (433) 123 4352"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")