re = /:\s\+?(\(?[0-9]+\)?\s?)+/m
str = 'tel/mob: 001 433 123 4352
tel/mob: 0014331234352
tel: 001 433 123 4352
tel: 0014331234352
tel/mob: 001 (433) 123 4352
tel: 001 (433) 123 4352
tel/mob: +1 433 123 4352
tel/mob: +14331234352
tel: +1 433 123 4352
tel: +14331234352
tel/mob: +1 (433) 123 4352
tel: +1 (433) 123 4352'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end