import re
regex = re.compile(r":\s\+?(\(?[0-9]+\)?\s?)+", flags=re.MULTILINE)
test_str = ("tel/mob: 001 433 123 4352\n"
"tel/mob: 0014331234352\n"
"tel: 001 433 123 4352\n"
"tel: 0014331234352\n"
"tel/mob: 001 (433) 123 4352\n"
"tel: 001 (433) 123 4352\n"
"tel/mob: +1 433 123 4352\n"
"tel/mob: +14331234352\n"
"tel: +1 433 123 4352\n"
"tel: +14331234352\n"
"tel/mob: +1 (433) 123 4352\n"
"tel: +1 (433) 123 4352")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")