using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+\s+in\s)";
string input = @"DEMO2 in ( ""test1"", ""test2"", ""test3""), CODE_ID in ( ""test4"", ""test5"", ""test6"")";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}