re = /(\w+\s+in\s)/m
str = 'DEMO2 in ( "test1", "test2", "test3"), CODE_ID in ( "test4", "test5", "test6")'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end