$re = '/(\w+\s+in\s)/m';
$str = 'DEMO2 in ( "test1", "test2", "test3"), CODE_ID in ( "test4", "test5", "test6")';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);