// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\w+\s+in\s)").unwrap();
let string = "DEMO2 in ( \"test1\", \"test2\", \"test3\"), CODE_ID in ( \"test4\", \"test5\", \"test6\")";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}