#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^(?:.+?\b\s+?\b){20}"
Local $sString = "one two three four five six seven eight nine ten eleven" & @CRLF & _
"twelve thirteen fourteen fifteen" & @CRLF & _
"sixteen seventeen" & @CRLF & _
"eighteen nineteen twenty twentyone twentytwo"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")