import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:.+?\\b\\s+?\\b){20}";
final String string = "one two three four five six seven eight nine ten eleven\n"
+ "twelve thirteen fourteen fifteen\n"
+ "sixteen seventeen\n"
+ "eighteen nineteen twenty twentyone twentytwo";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}