package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(?:.+?\b\s+?\b){20}`)
var str = `one two three four five six seven eight nine ten eleven
twelve thirteen fourteen fifteen
sixteen seventeen
eighteen nineteen twenty twentyone twentytwo`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}