// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(?:.+?\b\s+?\b){20}").unwrap();
let string = "one two three four five six seven eight nine ten eleven
twelve thirteen fourteen fifteen
sixteen seventeen
eighteen nineteen twenty twentyone twentytwo";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}