re = /^(?:.+?\b\s+?\b){20}/
str = 'one two three four five six seven eight nine ten eleven
twelve thirteen fourteen fifteen
sixteen seventeen
eighteen nineteen twenty twentyone twentytwo'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end