#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)/([^/.]+)$"
Local $sString = "www.mysite.com/page" & @CRLF & _
"www.mysite.com/page/" & @CRLF & _
"www.mysite.com/file.php"
Local $sSubst = "/$1/"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)