$re = '`/([^/.]+)$`m';
$str = 'www.mysite.com/page
www.mysite.com/page/
www.mysite.com/file.php';
$subst = "/$1/";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;