re = /\/([^\/.]+)$/m
str = 'www.mysite.com/page
www.mysite.com/page/
www.mysite.com/file.php'
subst = '/$1/'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result