const regex = new RegExp('/([^/.]+)$', 'gm')
const str = `www.mysite.com/page
www.mysite.com/page/
www.mysite.com/file.php`;
const subst = `/$1/`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);