package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)/([^/.]+)$`)
var str = `www.mysite.com/page
www.mysite.com/page/
www.mysite.com/file.php`
var substitution = "/$1/"
fmt.Println(re.ReplaceAllString(str, substitution))
}