const regex = /^((\d{4}).(\d{2}).(\d{1}).(\d{1,3}).(\d{1,3}))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((\\d{4}).(\\d{2}).(\\d{1}).(\\d{1,3}).(\\d{1,3}))', 'gm')
const str = `2018.30.3.0.4
SS.InSite-2018.30.3.0.4
2018.30.3.0.4
2018.30.3.0.4
2018.30.3.0.4TEst
20181.30.3.0.4
2018.301.3.0.4
2018.30.3.0.4
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}