import re
regex = re.compile(r"^((\d{4}).(\d{2}).(\d{1}).(\d{1,3}).(\d{1,3}))", flags=re.MULTILINE)
test_str = ("2018.30.3.0.4\n"
"SS.InSite-2018.30.3.0.4\n"
"2018.30.3.0.4\n"
"2018.30.3.0.4 \n"
"2018.30.3.0.4TEst\n"
"20181.30.3.0.4\n"
"2018.301.3.0.4 \n"
"2018.30.3.0.4\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")