$re = '/^((\d{4}).(\d{2}).(\d{1}).(\d{1,3}).(\d{1,3}))/m';
$str = '2018.30.3.0.4
SS.InSite-2018.30.3.0.4
2018.30.3.0.4
2018.30.3.0.4
2018.30.3.0.4TEst
20181.30.3.0.4
2018.301.3.0.4
2018.30.3.0.4
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);