package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\|(?<type>.*?)\|(?<id>.*?)\|(?<message>.*)\|(?<code>[0-9]+)\|\|$`)
var str = `|null|23|2017-07-11T19:03:40.511|Test|PageUnque#MasterCache|123450000||`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}