$re = '/^\|(?<type>.*?)\|(?<id>.*?)\|(?<message>.*)\|(?<code>[0-9]+)\|\|$/';
$str = '|null|23|2017-07-11T19:03:40.511|Test|PageUnque#MasterCache|123450000||';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);