const regex = /^\|(?<type>.*?)\|(?<id>.*?)\|(?<message>.*)\|(?<code>[0-9]+)\|\|$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\|(?<type>.*?)\\|(?<id>.*?)\\|(?<message>.*)\\|(?<code>[0-9]+)\\|\\|$', 'g')
const str = `|null|23|2017-07-11T19:03:40.511|Test|PageUnque#MasterCache|123450000||`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}