re = /^\|(?<type>.*?)\|(?<id>.*?)\|(?<message>.*)\|(?<code>[0-9]+)\|\|$/
str = '|null|23|2017-07-11T19:03:40.511|Test|PageUnque#MasterCache|123450000||'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end