import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\|(?<type>.*?)\\|(?<id>.*?)\\|(?<message>.*)\\|(?<code>[0-9]+)\\|\\|$";
final String string = "|null|23|2017-07-11T19:03:40.511|Test|PageUnque#MasterCache|123450000||";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}