using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:([0-8])(?!\1\1)|9){10,25}$";
string input = @"Need help to stop user from entering phone number with three or more repeated digits except 999. Phone number could be 10 digit to 25 digit.
Bad Input
8777267331
000
6666787876
Exception.
767886655999
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}