const regex = new RegExp('^(?:([0-8])(?!\\1\\1)|9){10,25}$', 'gm')
const str = `Need help to stop user from entering phone number with three or more repeated digits except 999. Phone number could be 10 digit to 25 digit.
Bad Input
8777267331
000
6666787876
Exception.
767886655999
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}