re = /^(?:([0-8])(?!\1\1)|9){10,25}$/m
str = 'Need help to stop user from entering phone number with three or more repeated digits except 999. Phone number could be 10 digit to 25 digit.
Bad Input
8777267331
000
6666787876
Exception.
767886655999
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end