import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:([0-8])(?!\\1\\1)|9){10,25}$";
final String string = "Need help to stop user from entering phone number with three or more repeated digits except 999. Phone number could be 10 digit to 25 digit.\n\n"
+ "Bad Input\n"
+ "8777267331\n"
+ "000\n"
+ "6666787876\n\n"
+ "Exception.\n"
+ "767886655999\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}