use strict;
my $str = 'Need help to stop user from entering phone number with three or more repeated digits except 999. Phone number could be 10 digit to 25 digit.
Bad Input
8777267331
000
6666787876
Exception.
767886655999
';
my $regex = qr/^(?:([0-8])(?!\1\1)|9){10,25}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}