using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<greek_letter>\\?\\(?:alpha|[bz]?eta|(?:dig|g|G)amma|[Dd]elta|[Uue]psilon|[Tt]heta|iota|kappa|[Ll]ambda|[mn]u|[Xx]i|[Pp]i|rho|[Ss]igma|tau|[Pp][hs]i|chi|[Oo]mega|var(?:epsilon|theta|rho|ph?i|kappa|sigma)))";
string input = @"Include
\alpha \beta \gamma \Gamma \delta \Delta \epsilon \varepsilon \zeta \eta \theta \vartheta \Theta \iota \kappa \lambda \Lambda \mu \nu \xi \Xi \pi \Pi \rho \varrho \sigma \Sigma \tau \upsilon \Upsilon \phi \varphi \Phi \chi \psi \Psi \omega \Omega \varkappa \varpi \varsigma
Exclude
\Alpha \Beta \vargamma \Epsilon \Zeta \Eta \Iota \Kappa \Mu \Nu \Rho \Tau \Chi \varpsi \varPhi
https://www.overleaf.com/learn/latex/List_of_Greek_letters_and_math_symbols";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}