use strict;
my $str = 'Include
\\alpha \\beta \\gamma \\Gamma \\delta \\Delta \\epsilon \\varepsilon \\zeta \\eta \\theta \\vartheta \\Theta \\iota \\kappa \\lambda \\Lambda \\mu \\nu \\xi \\Xi \\pi \\Pi \\rho \\varrho \\sigma \\Sigma \\tau \\upsilon \\Upsilon \\phi \\varphi \\Phi \\chi \\psi \\Psi \\omega \\Omega \\varkappa \\varpi \\varsigma
Exclude
\\Alpha \\Beta \\vargamma \\Epsilon \\Zeta \\Eta \\Iota \\Kappa \\Mu \\Nu \\Rho \\Tau \\Chi \\varpsi \\varPhi
https://www.overleaf.com/learn/latex/List_of_Greek_letters_and_math_symbols';
my $regex = qr/(?<greek_letter>\\?\\(?:alpha|[bz]?eta|(?:dig|g|G)amma|[Dd]elta|[Uue]psilon|[Tt]heta|iota|kappa|[Ll]ambda|[mn]u|[Xx]i|[Pp]i|rho|[Ss]igma|tau|[Pp][hs]i|chi|[Oo]mega|var(?:epsilon|theta|rho|ph?i|kappa|sigma)))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}